前言: 以下設定 都先假設已建好鄰居關係並可正常收發彼此路由資訊
僅做 有關 default route 的設定
=============================================
實驗的網路拓樸
--
R1作為送出 default route
R1(config)#router rip
R1(config-router)#default-information originate ## 送出gateway 資訊
R1(config-router)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback 0 ## 此範例 以 static 產生 default route
此為鄰居經由 RIP 得到 gateway 的 示意圖 ( 特權模式下 show ip route )
## RIP 產生預設路由給別人時 自己的路由表要先有 default route 不論是何種方式產生
## 這裡使用 static route 先為自己產生
(我所知道的,有四種)
--
第一種 (先產生一條靜態預設路由 , 並將其 redistribute to EIGRP)
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback 0 ## 先設定 靜態預設路由
R1(config)#router eigrp 1
R1(config-router)#redistribute static ## 將 靜態路由 redistribute to EIGRP
鄰居取得 gateway 的示意圖 ( D*EX 中 EX 表示由 外部( 經由 redistribute ) 取得的路由資訊)
##
##這裡為了簡單實驗 使用 loopback 假裝 對外出口
===
第二種: (跟第一種基本一樣,只是宣告進去eigrp 的方式不同)
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback 0
R1(config)#router eigrp 1
R1(config-router)#network 0.0.0.0 ## 這裡宣告使用 network => 即此路由資訊是 "internal" ,而第一種則是 "external"
鄰居取得 gateway 的示意圖
##
## 缺點是使用 network 0.0.0.0 造成所有介面都啟動
## 可以使用 passive-interface 做修飾
## 跟 第一種 比較其 AD => 第一種是 external ( AD 170 ) 第二種 internal ( AD 90 )
===
第三種: (使用路徑總結的方式)
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip summary-address eigrp 1 0.0.0.0 0.0.0.0 ## 指令簡單介紹 ip summary eigrp <ASN> <ip address> <netmask>
鄰居取得 gateway 的示意圖 ( 此次使用 路徑總結方式宣告 )
##
## R1 上並不需要 先有 default gateway
## 缺點: 具方向性宣告, 如以上設定 就只有宣告給interface 0/0 的鄰居
===
第四種: (使用 ip default-network )
這裡更改為這樣的環境,R1 和 R2 建立 EIGRP Neighbor
由R1 送出 default route 給 EIGRP_Neighbor
R1(config-if)#router eigrp 1
R1(config-router)#network 10.0.0.0
R1(config-router)#exit
R1(config)#ip default-network 10.0.0.0 ## 使用 ip default-network 指定的網路必須是主網路,且有宣告在 EIGRP 中
EIGRP_Neighor 取得gateway 示意圖
## 此實驗 ip default-network < ip address> 該 ip address 需為 R1 的主網路 (即 interface 中有該網段)
##
--
網路拓樸 同 RIP `,設定也同 RIP
R1(config)#router ospf 1
R1(config-router)#default-information
R1(config-router)#default-information originate ## 同 RIP 宣告 default route ,需本身路由表已有default route
R1(config-router)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback 0 ## 此範例 以 static 產生 default route
鄰居得到gateway 示意圖
## 如果在 default-information originate 加上 always => default-information originate always
## 則就算 routing-table 沒有 default route 也會強制送出default route 的資訊給鄰居